The affected products are: TS-4710, TS-4712, TS-4720, TS-8150-4710, TS-8150-4712, TS-8150-4720, TS-8700-4710, TS-8820-4710, TS-8820-4712, TS-TPC-8380-4712, TS-TPC-8380-4720, TS-TPC-8390-4710, TS-TPC-8390-4720, TS-TPC-8920-4712, TS-TPC-8920-4720The new Linux 2.6 image that will be loaded on these products will include: a fix for the second ethernet port on the TS-4740, integrated CAN support on the TS-7250-V2 when using FPGA rev 9 bitstream, and support for the full sized SD card socket on the TS-7250-V2.We are also changing the default behavior of DIO9 on pin 73 of CN1 on some base boards and any custom base boards so that is it no longer defaults to a software reset request on boards that do not have a push button (refer to the User Manual on the website for more details)More information is available here: If you are using the Linux 3.14 image for these products in your application, there is a related Linux 3.14 software release available on our website that contains these same bug fixes. Technologic Systems appreciates your business.If you have further questions or concerns, please contact us by either replying to this email or filling out the contact us form at

updating image linux 2 6 32 9-3

dpkg: error processing linux-image-2.6.32-24-generic-pae (--configure): subprocess installed post-installation script returned error exit status 2 Errors were encountered while processing: linux-image-2.6.32-24-generic-pae E: Sub-process /usr/bin/dpkg returned an error code (1)~$ sudo apt-get upgrade Reading package lists... Found kernel: /boot/vmlinuz-2.6.32-25-generic-pae Found kernel: /boot/vmlinuz-2.6.32-24-generic-pae Found kernel: /boot/vmlinuz-2.6.24-19-server Found kernel: /boot/vmlinuz-2.6.15-27-server Found kernel: /boot/memtest86+Updating /boot/grub/... run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.32-25-generic-pae /boot/vmlinuz-2.6.32-25-generic-pae run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10 Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.32-25-generic-pae.postinst line 1003.

Done Building dependency tree Reading state information... and at the end of the process (using any of the commands posted above) I get the initial snippet I posted as the result. Anyone have a similar problem or know how to clean things up here? Update: After receiving a notice from Landscape that my server was still in need of upgrading the new kernel packages I attempted the upgrade once again, and it seems to get a bit further ... Found kernel: /boot/vmlinuz-2.6.32-25-generic-pae Found kernel: /boot/vmlinuz-2.6.32-24-generic-pae Found kernel: /boot/vmlinuz-2.6.24-19-server Found kernel: /boot/vmlinuz-2.6.15-27-server Found kernel: /boot/memtest86+Updating /boot/grub/... run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.32-24-generic-pae /boot/vmlinuz-2.6.32-24-generic-pae run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10 Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.32-24-generic-pae.postinst line 1003. found: /boot/grub/default Testing for an existing GRUB file ... dpkg: error processing linux-image-2.6.32-25-generic-pae (--configure): subprocess installed post-installation script returned error exit status 2 dpkg: dependency problems prevent configuration of linux-image-generic-pae: linux-image-generic-pae depends on linux-image-2.6.32-25-generic-pae; however: Package linux-image-2.6.32-25-generic-pae is not configured yet.

Done 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. After this operation, 0B of additional disk space will be used. an error still persists: [email protected]:~$ sudo apt-get upgrade Reading package lists... found: /boot/grub/default Testing for an existing GRUB file ... dpkg: error processing linux-image-2.6.32-24-generic-pae (--configure): subprocess installed post-installation script returned error exit status 2 Setting up linux-image-2.6.32-25-generic-pae (2.6.32-25.44) ... update-initramfs: Generating /boot/initrd.img-2.6.32-25-generic-pae Running postinst hook script /usr/sbin/update-grub. dpkg: error processing linux-image-generic-pae (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of linux-generic-pae: linux-generic-pae depends on linux-image-generic-pae (= 2.6.); however: Package linux-image-generic-pae is not configured yet. Found kernel: /boot/vmlinuz-2.6.32-25-generic-pae Found kernel: /boot/vmlinuz-2.6.32-24-generic-pae Found kernel: /boot/vmlinuz-2.6.24-19-server Found kernel: /boot/vmlinuz-2.6.15-27-server Found kernel: /boot/memtest86+Updating /boot/grub/... run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.32-25-generic-pae /boot/vmlinuz-2.6.32-25-generic-pae run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10 Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.32-25-generic-pae.postinst line 1003.

Done Building dependency tree Reading state information... After this operation, 0B of additional disk space will be used. Get:1 lucid-updates/main linux-generic-pae 2.6. [4,122B] Get:2 lucid-updates/main linux-image-generic-pae 2.6. [4,128B] Fetched 8,250B in 0s (15.7k B/s) (Reading database ... update-initramfs: Generating /boot/initrd.img-2.6.32-24-generic-pae Not updating initrd symbolic links since we are being updated/reinstalled (2.6.32-24.42 was configured last, according to dpkg) Not updating image symbolic links since we are being updated/reinstalled (2.6.32-24.42 was configured last, according to dpkg) Running postinst hook script /usr/sbin/update-grub. dpkg: error processing linux-generic-pae (--configure): dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure. found: /boot/grub/default Testing for an existing GRUB file ... dpkg: error processing linux-image-2.6.32-25-generic-pae (--configure): subprocess installed post-installation script returned error exit status 2 dpkg: dependency problems prevent configuration of linux-image-generic-pae: linux-image-generic-pae depends on linux-image-2.6.32-25-generic-pae; however: Package linux-image-2.6.32-25-generic-pae is not configured yet.

Done The following packages will be upgraded: linux-generic-pae linux-image-generic-pae 2 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 164009 files and directories currently installed.) Preparing to replace linux-generic-pae 2.6. (using .../linux-generic-pae_2.6._i386.deb) ... Preparing to replace linux-image-generic-pae 2.6. (using .../linux-image-generic-pae_2.6._i386.deb) ... Setting up linux-image-2.6.32-24-generic-pae (2.6.32-24.43) ... No apport report written because Max Reports is reached already Errors were encountered while processing: linux-image-2.6.32-24-generic-pae linux-image-2.6.32-25-generic-pae linux-image-generic-pae linux-generic-pae E: Sub-process /usr/bin/dpkg returned an error code (1) [email protected]:~$ sudo dpkg --configure -a Setting up linux-image-2.6.32-25-generic-pae (2.6.32-25.44) ... update-initramfs: Generating /boot/initrd.img-2.6.32-25-generic-pae Running postinst hook script /usr/sbin/update-grub. dpkg: error processing linux-image-generic-pae (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of linux-generic-pae: linux-generic-pae depends on linux-image-generic-pae (= 2.6.); however: Package linux-image-generic-pae is not configured yet.

dpkg: error processing linux-generic-pae (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: linux-image-2.6.32-25-generic-pae linux-image-generic-pae linux-generic-pae In fact, after doing this the system required a restart, and I had purged ALL of the kernel images on the system - duh! Found kernel: /boot/vmlinuz-2.6.32-25-generic-pae Found kernel: /boot/vmlinuz-2.6.32-25-generic Found kernel: /boot/memtest86+Updating /boot/grub/... run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.32-25-generic-pae /boot/vmlinuz-2.6.32-25-generic-pae run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10 Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.32-25-generic-pae.postinst line 1003.

Using the server edition install CD for lucid 10.04 I was able to use rescue mode to re-install the current kernel image (linux-image-2.6.32-25-generic) and successfully rebooted the system - and my web server is back in operation. Found kernel: /boot/vmlinuz-2.6.32-25-generic-pae Found kernel: /boot/vmlinuz-2.6.32-25-generic Found kernel: /boot/memtest86+Updating /boot/grub/... run-parts: executing /etc/kernel/postinst.d/nvidia-common 2.6.32-25-generic /boot/vmlinuz-2.6.32-25-generic run-parts: /etc/kernel/postinst.d/nvidia-common exited with return code 10 Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-2.6.32-25-generic.postinst line 1003. found: /boot/grub/default Testing for an existing GRUB file ... dpkg: error processing linux-image-2.6.32-25-generic-pae (--configure): subprocess installed post-installation script returned error exit status 2 dpkg: dependency problems prevent configuration of linux-image-generic: linux-image-generic depends on linux-image-2.6.32-25-generic; however: Package linux-image-2.6.32-25-generic is not configured yet.

Notice Id: 13 Type: OS Update Effective On: Jan 22, 2016 Published: January 08, 2016 Products Affected: TS-4710, TS-4712, TS-4720, TS-8150-4710, TS-8150-4712, TS-8150-4720, TS-8700-4710, TS-8820-4710, TS-8820-4712, TS-TPC-8380-4712, TS-TPC-8380-4720, TS-TPC-8390-4710, TS-TPC-8390-4720, TS-TPC-8920-4712, TS-TPC-8920-4720 Dear Valued Customer, We are contacting you today to notify you of our plans to Update to the Preloaded Linux 2.6 Image on TS-4710, TS-4712, TS-4720 from Technologic Systems.

There are several bugs in the existing image that this update will correct to improve the product.